Email config help

Hi,
I’m woring on a dockerfile for Hitobito. I already got it working with the hitobito_default wagon.

I’m struggling a bit with the email settings. I don’t know which is the correct format:

with this “RAILS_MAIL_DELIVERY_CONFIG=address: 172.22.1.1,port: 25” the container crashes with an error about “:” characters"

I also tried this one but it does not seem to be working.
RAILS_MAIL_DELIVERY_CONFIG={address: ‘172.22.1.1’,port: 25}

any ideas?

well now I got the configuration working. BUT:

Now I get the following errors from the server:

|6/6/2019, 5:31:26 PM|info|disconnect from unknown[172.22.1.1] ehlo=1 starttls=1 commands=2|
|---|---|---|
|6/6/2019, 5:31:26 PM|info|lost connection after STARTTLS from unknown[172.22.1.1]|
|6/6/2019, 5:31:26 PM|info|Anonymous TLS connection established from unknown[172.22.1.1]: TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)|
|6/6/2019, 5:31:26 PM|info|connect from unknown[172.22.1.1]|

I read that this might be because of the client does not support the right SSL version. Any ideas?

Hi Juca

I noticed that someone else is also working on dockerizing hitobito: https://github.com/hitobito/hitobito/pull/774, albeit for a development/test setup. For production and integration, we mostly use external mail-servers or -services.

From the log you posted it seems like you want to have a mailserver in another container. If this is for testing and development, I would suggest mailcatcher. It listens by default on Port 8025, but can be configured. See the Procfile for the intended usage.

Which environment are you targeting?

Ok thanks!

I think I solved the issue by using the port 587.

1 Like